# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\"(.+?)\"|([^\s]+)).*/$1$2/gm;t' <<< "c:\tools\foo.exe
c:\tools\foo.exe -bar
\"C:\Program Files\bar.exe\"
\"C:\Program Files\bar.exe\" -baz
"