const regex = new RegExp('^(?:\\"(.+?)\\"|([^\\s]+)).*', 'gm')
const str = `c:\\tools\\foo.exe
c:\\tools\\foo.exe -bar
"C:\\Program Files\\bar.exe"
"C:\\Program Files\\bar.exe" -baz
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);