$re = '/.*:\/\/.*|(\/\/.*)/m';
$str = 'http://bla
// some comment
function () { // another comment
asdf asdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);