import Foundation
let pattern = #"companyholder\.do[\S]+symbol\=([\w\d-]+(?=&|\n))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.set.or.th/set/companyholder.do?symbol=EMC
https://www.set.or.th/set/companyholder.do?symbol=EMC&language=th&country=TH
https://www.set.or.th/set/companyholder.do%3Bjsessionid=B08A576398DF62A466D1D08EAAF280CC?symbol=BLAND-F&language=en&country=EN
https://www.set.or.th/set/newsdetails.do?newsId=14828768298911&language=th&country=TH
https://www.set.or.th/set/companyholder.do?symbol=RML-F&ssoPageId=6&language=th&country=TH
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)