$re = '/\b[A-Z]+(?!19\b)\d*\b;?/m';
$str = 'ABCD17; ABC18; ABCEF19; XYZ19; ABCDE
ABCEF199; XYZ1999; ABCDE';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;