using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<ValueTolerance>([^\w|\S])([\±]+?\d+?[%])([\s]))";
string input = @"SMD 0603 q49 ,91111111 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 123.999Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9ккОм ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 9.99Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 9.99кОм ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 МОм ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49.9 ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9МОм ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 мОм ±1% 0.11 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 мкОм ± 1% 0.11Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX
ads 50.9Ом erterter
50.99Вт
50.9 В
50.999 Вт
а50 мФ
100.00 мкФ
100.00 нФ
100.00 пФ
10 мкФ
0123456789 мФ
0,123456789 мФ
0.123456789 мФ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}