use strict;
my $str = 'SMD 0603 q49 ,91111111 Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 123.999Ом ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9ккОм ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 9.99Ом ±1% 0,1 Вт CR0603-FX-49R9ELF
SMD 0603 9.99кОм ± 1% 0,1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 МОм ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49.9 ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9МОм ±1% 0.1 Вт CR0603-FX-49R9ELF
SMD 0603 49,9ГОм ± 1% 0.1Вт CR0603-FX-49R9ELF
SMD 0603 49,9 мОм ±1% 0.11 Вт CR0603-FX-49R9ELF
SMD 0603 49,9 мкОм ± 1% 0.11Вт CR0603-FX-49R9ELF
SMD 0805 100 нФ ± 10 % 50 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ± 10 % 50.0 В X7R 08055C104KAT2A AVX
SMD 0805 100 нФ ±10% 50.0В X7R 08055C104KAT2A AVX
ads 50.9Ом erterter
50.99Вт
50.9 В
50.999 Вт
а50 мФ
100.00 мкФ
100.00 нФ
100.00 пФ
10 мкФ
0123456789 мФ
0,123456789 мФ
0.123456789 мФ';
my $regex = qr/(?<ValueTolerance>([^\w|\S])([\±]+?\d+?[%])([\s]))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}