#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=value=")[^"]*(?=.*1920×1277)"
Local $sString = "water-3326310_1920.jpg" & @CRLF & _
"" & @CRLF & _
" <tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>" & @CRLF & _
"" & @CRLF & _
"<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")