import Foundation
let pattern = #"(?<=value=")[^"]*(?=.*1920×1277)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
water-3326310_1920.jpg
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)