import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([a-zA-Z]:[/\\\\]|\\\\\\\\)([0-9a-zA-Z_\\-. ]+[/\\\\]?)*)|([0-9a-zA-Z_\\-\\\\/.][0-9a-zA-Z_\\-\\\\/. ]*)|(^$)";
final String string = "/test.txt\n"
+ "test.txt\n"
+ "C:\\test.txt\n"
+ "D:\\test\\test2.txt\n"
+ " asdfasdf \n"
+ "abcd :Dasdfrew\n"
+ "hbkj23j;nlkfsld khjasdf\n"
+ "adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs\n"
+ "test/test.txt\n"
+ "C:/test.txt\n"
+ "C:\\test/test.txt\n"
+ "C:\\/test.txt\n"
+ "C:/\\test.txt\n"
+ "aa:\\\n"
+ "C:\\\\test.txt\n"
+ "C:/\\test.txt\n"
+ "\\test.txt\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}