# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(([a-zA-Z]:[/\\]|\\\\)([0-9a-zA-Z_\-. ]+[/\\]?)*)|([0-9a-zA-Z_\-\\/.][0-9a-zA-Z_\-\\/. ]*)|(^$)"
test_str = ("/test.txt\n"
"test.txt\n"
"C:\\test.txt\n"
"D:\\test\\test2.txt\n"
" asdfasdf \n"
"abcd :Dasdfrew\n"
"hbkj23j;nlkfsld khjasdf\n"
"adsfpoiuhasef pn9y8hqwer 98uhqwef;olnkqw234r'l;,qwetfs\n"
"test/test.txt\n"
"C:/test.txt\n"
"C:\\test/test.txt\n"
"C:\\/test.txt\n"
"C:/\\test.txt\n"
"aa:\\\n"
"C:\\\\test.txt\n"
"C:/\\test.txt\n"
"\\test.txt\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.