const regex = /^(03|04)[1-9]{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(03|04)[1-9]{8}$', 'gm')
const str = `0376876768
046786988989877789787h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}