#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<myRequiredData>(http(s)*:\/\/)[^\/\s]+)"
Local $sString = "http://10.2.3.44:8080" & @CRLF & _
"http://1.3.2.55:8011/Login.aspx" & @CRLF & _
"https://wwx.ff-ac.com/login" & @CRLF & _
"https://192.443.67.91:8044/bs_y/index.jsp" & @CRLF & _
"http://rr-ww.ff-ac.com/rr_platform_ww/ayyu" & @CRLF & _
"https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")