use strict;
my $str = 'Jim G G Bob
Jim G. G. Bob
Tom H H H Ford
Sarah H Howard';
my $regex = qr/\b(\pL\W+)\1+/up;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";