re = /(['"])[^'"]*\1|[-*\/%+]/
str = 'var x = \'person + arthur\' + "family + all";'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end