$re = '/\*(?=\S).*?(?<=[^\s*])\*(?!\S)/';
$str = '*foo 1 * 2 bar* foo *b* azz *qu **ux*
*****foo 1 * 2 bar* foo *b* azz *qu **ux*
** some text
so * this one* should not be matched
*this one * and *this o*ne should not be matched
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);