$re = '/^[a-zA-Z.!#$%&\'+/=?^_`{|}~-][a-zA-Z0-9.!#$%&\'+/=?^_`{|}~-]*@
/m';
$str = 'a@
1@
b123@
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);