// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"OPTIONS=\"(.*?)(-u\s[A-Za-z0-9\-_]+:[A-Za-z0-9\-_]+)?(.*?)\""#).unwrap();
let string = "OPTIONS=\"-x -u wrong:wrong -c blah\"
OPTIONS=\"-u wrong:wrong -x -c blah\"
OPTIONS=\"-x -c blah -u wrong:wrong\"
OPTIONS=\"-x -c blah\"
";
let substitution = "OPTIONS=\"\\1 \\3 -u ntpd:ntpd\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}