import Foundation
let pattern = ##"^.+\s?{{#link-to '(?:(?!home).{0,4}.*)'}}"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
1st test
a {{#link-to 'route-name'}}
b {{#link-to 'route-name'}}
c {{#link-to 'route-name'}}
abc {{#link-to 'route-name'}}
home {{#link-to 'route-name'}}
zhome-main {{#link-to 'route-name'}}
home-main {{#link-to 'route-name'}}
test{{#link-to 'route-name'}}
2nd test
a {{#link-to ''}}
b {{#link-to 'name'}}
c {{#link-to 'route-home'}}
d {{#link-to 'homee'}}
e {{#link-to 'home'}}
f {{#link-to 'home - weq'}}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)