$re = '/a(?:x{7,8})?b/m';
$str = 'abaxbaxxxxxxbaxxxxxxxbaxxxxxxxxbaxxxxxxxxxxb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);