#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?\/)\d{4}-\d{2}-\d{2}$"
Local $sString = "" & @CRLF & _
"my-file-path/wefw/wefw/2022-03-20" & @CRLF & _
"my-file-path/wefw/2022-01-02" & @CRLF & _
"my-file-path/wef/wfe/wefw/wef/2021-02-03" & @CRLF & _
"my-file-path/wef/wfe/wef/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")