package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?U)(<td.*style=".*)(;)(".*>)(?:In order to stop receiving)`)
var str = []byte(`<tr>
<td style="color:#555555;padding-top: 3px;padding-bottom: 20px;">In order to stop receiving similar emails, simply remove the relevant <a href="https://domain.tld/dashboard/?module=saved-searches" target="_blank">saved search</a> from your account.</td>
</tr>`)
var substitution = []byte("$1$2$3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}