use strict;
my $str = '<tr>
<td style="color:#555555;padding-top: 3px;padding-bottom: 20px;">In order to stop receiving similar emails, simply remove the relevant <a href="https://domain.tld/dashboard/?module=saved-searches" target="_blank">saved search</a> from your account.</td>
</tr>';
my $regex = qr/(<td.*style=".*)(;)(".*>)(?:In order to stop receiving)/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";