use strict;
my $str = '111 is different from:
111 is different from:
123 is different from:
567.';
my $regex = qr/(?m)^(\d{3}) .+:(\r?\n)(?!\1)(?=(\d{3})\b)/ip;
my $subst = '$0 This value $3 ***$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";