package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\\$.*?\$|\$.*?\\\$|(\$.*?\$)`)
var str = `escaping the syntax, e.g. The price is 5\$ to 10\$ or $ to \$ or \$ to $ or capture $ to $`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}