re = /<div[^>]*>([\s\S]*)<\/div>/m
str = '<div class="1">
abc
<div>div interna</div>
xyz
</div>
<div>outra</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end