const regex = /(\d{1})(\d{3})(\d{3})\d{0}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1})(\\d{3})(\\d{3})\\d{0}', '')
const str = `16478669239`;
const subst = `+$1($2)-XXX-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);