$re = '/^(?:[а-яё]+|[a-z]+)$/imu';
$str = 'Кириллица
Latin
LatinКириллица';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);