$re = '/^\s*\S*\s*<artifactID>nginx-node<\/artifactID>\s*\S*\s*$/m';
$str = ' <groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.0</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.1</version>
<groupID>com.test</groupID>
<artifactID>nginx</artifactID>
<verion>1.2</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.0</version>
<groupID>com.test</groupID>
<artifactID>nginx-node</artifactID>
<verion>1.1</version>
<groupID>com.test</groupID>
<artifactID>nginx</artifactID>
<verion>1.2</version>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);