#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""([^"]+)":"
Local $sString = "{ "name": "J\\"ohn Smith" }" & @CRLF & _
"" & @CRLF & _
"{" & @CRLF & _
" "colors": [" & @CRLF & _
" {" & @CRLF & _
" "color": "black"," & @CRLF & _
" "category": "hue"," & @CRLF & _
" "type": "primary"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [255,255,255,1]," & @CRLF & _
" "hex": "#000"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "color": "white"," & @CRLF & _
" "category": "value"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [0,0,0,1]," & @CRLF & _
" "hex": "#FFF"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "color": "red"," & @CRLF & _
" "category": "hue"," & @CRLF & _
" "type": "primary"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [255,0,0,1]," & @CRLF & _
" "hex": "#FF0"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "color": "blue"," & @CRLF & _
" "category": "hue"," & @CRLF & _
" "type": "primary"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [0,0,255,1]," & @CRLF & _
" "hex": "#00F"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "color": "yellow"," & @CRLF & _
" "category": "hue"," & @CRLF & _
" "type": "primary"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [255,255,0,1]," & @CRLF & _
" "hex": "#FF0"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "color": "green"," & @CRLF & _
" "category": "hue"," & @CRLF & _
" "type": "secondary"," & @CRLF & _
" "code": {" & @CRLF & _
" "rgba": [0,255,0,1]," & @CRLF & _
" "hex": "#0F0"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" ]" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")