$re = '/^((1558[0-9]{6})|(310[0-9]{9}))$/m';
$str = '1558218374
1559218374
1234567899
2155817896
310123456789
311123456789
131023456789
123456789999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);