package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\(%MSG_ID%\)]+`)
var str = `Expander Detected (%MSG_ID%)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}