#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_inherit = 'res\.partner'(?s:.*?)unique_code.*"
Local $sString = "_inherit = 'res.partner' " & @CRLF & _
"" & @CRLF & _
"parent_company = fields.Many2one('res.partner', 'Parent Company') " & @CRLF & _
"unique_code = fields.Char(string='Unique client code', readonly="1",copy=False, index=True) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")