package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)_inherit = 'res\.partner'(?s:.*?)unique_code.*`)
var str = `_inherit = 'res.partner'
parent_company = fields.Many2one('res.partner', 'Parent Company')
unique_code = fields.Char(string='Unique client code', readonly="1",copy=False, index=True) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}