const regex = new RegExp('_inherit = \\'res\\.partner\\'(?s:.*?)unique_code.*', 'gm')
const str = `_inherit = 'res.partner'
parent_company = fields.Many2one('res.partner', 'Parent Company')
unique_code = fields.Char(string='Unique client code', readonly="1",copy=False, index=True) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}