re = /_inherit = 'res\.partner'(?s:.*?)unique_code.*/m
str = '_inherit = \'res.partner\'
parent_company = fields.Many2one(\'res.partner\', \'Parent Company\')
unique_code = fields.Char(string=\'Unique client code\', readonly="1",copy=False, index=True) '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end