// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)_inherit = 'res\.partner'(?s:.*?)unique_code.*").unwrap();
let string = "_inherit = 'res.partner'
parent_company = fields.Many2one('res.partner', 'Parent Company')
unique_code = fields.Char(string='Unique client code', readonly=\"1\",copy=False, index=True) ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}