$re = '/(?<=^Subject: )(?:(?!^Attachements:)[\s\S])+/m';
$str = 'From: me
To: you
Subject: welcome, this is a long line of subject with two
lines of text
Attachements: welcome.jpg, foo.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);