#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([\d]{4})[\-]([\d]{4})[\-]([\d]{4})[\-]([\d]{4})$"
Local $sString = "1234-5678-9012-3412" & @CRLF & _
"5645-6789-7897-9879" & @CRLF & _
"87979879879798798" & @CRLF & _
"13156465487987" & @CRLF & _
"54654 231321 45654 464 3213 5464 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")