import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\d]{4})[\\-]([\\d]{4})[\\-]([\\d]{4})[\\-]([\\d]{4})$";
final String string = "1234-5678-9012-3412\n"
+ "5645-6789-7897-9879\n"
+ "87979879879798798\n"
+ "13156465487987\n"
+ "54654 231321 45654 464 3213 5464 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}