re = /(?:[^\/]|(?<!\/)\/(?!\/))*МОСКВА.+?(?=\/\/|$)/
str = 'какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 // еще что-то
какая-то информация // фио персонажа // дом 10/2 адрес МОСКВА
дом 10/2 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end