package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-1]?\d|2[0-3])(?::([0-5]?\d))?(?::([0-5]?\d))`)
var str = `00:00:00
00:00:01
23:59:17
01:01:01
10:17:25
09:56:17
22:56:59
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}