package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)ab`)
var str = `1ab 2cd 3se 4ab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}