use strict;
my $str = '"name": "CapitalCaseWords"
"name": "AnotherStringSentence"
"ThisStringShouldntBeReplaced"';
my $regex = qr/("name":\ "[A-Z][a-z]+|(?<!^)\G)([A-Z][a-z]+)/mp;
my $subst = '\\1 \\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";