# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w*)\s(\w*)\n([^}])"
test_str = ("HEADER1:{\n"
"key value\n"
"key value\n"
"...\n"
"HEADER2:{\n"
"key value\n"
"...\n"
"},key value\n"
"HEADER3:{\n"
"key value\n"
"HEADER4:{\n"
"key value\n"
"...\n"
"}\n"
"},key value\n"
"}\n")
subst = "$1:$2,$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.