using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^1?\(\d{3}\)[-. ]?(\d{3})$";
string input = @"1(123)123
(123)123
1(123) 123
2(123) 123
1(123)%123
1(123)12
1(12)123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}