re = /.*Disconnected from (invalid |authenticating )?user .* [^ ]+ port [0-9]+( \[preauth\])?$/m
str = 'Jan 17 08:49:00 thesquareplanet.com sshd[2744]: Disconnected from invalid user wp-user 89.134.42.194 port 38866 [preauth]
Jan 17 03:13:00 thesquareplanet.com sshd[2631]: Disconnected from invalid user Disconnected from 46.97.239.16 port 55920 [preauth]
Jan 17 10:00:29 thesquareplanet.com sshd[2775]: Disconnected from user jon 18.26.4.53 port 39872'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end