# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x)^(?P<crt>crt) \n"
r"(?:\n"
r" (?:\n"
r" (?:_) (?P<sm>start_mode)(?P<ul>_)?(?P<smq>(?(ul)normal|ep))\n"
r" | (?:\n"
r" (?P<bool>[01])\B\n"
r" (?:_ \n"
r" (?: \n"
r" (?: (?P<dual>dual(?P<dq>ch))\n"
r" | (?P<ext>extended)(?P<q>ch|da|ep)\n"
r" | (?P<std>standard) \n"
r" | (?P<bstr>\w*)) ) | ) \n"
r" | (?: (?: (?P<digit>[2-9])(?:_)(?P<str>\w*))) )\n"
r" )\n"
r")$")
test_str = ("crt_start_mode_normal\n"
"crt_start_modeep\n"
"crt0_dualch\n"
"crt0_abc\n"
"crt1_xyzzy\n"
"crt2_abc\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.