$re = '/^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*\'P\'[ ]*and[ ]*o[.]name[ ]*=[ ]*\'\w*\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\'\w*\'[)][\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\S*[ ]*\s*[ ]*GO/mi';
$str = 'IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = \'P\' and o.name = \'DI_GetFidelityRetirementEnterprise\' and o.uid = u.uid and u.name = \'Escher\')
DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise
GO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);