// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^IF[ ]*EXISTS[ ]*[(]SELECT[ ]*1[ ]*FROM[ ]*sysobjects[ ]*o,[ ]*sysusers[ ]*u[ ]*WHERE[ ]*TYPE[ ]*=[ ]*'P'[ ]*and[ ]*o[.]name[ ]*=[ ]*\'\w*\'[ ]*AND[ ]*o[.]uid[ ]*=[ ]*u[.]uid[ ]*and[ ]*u[.]name[ ]*=[ ]*\'\w*\'[)][\s]*[ ]*DROP[ ]*PROCEDURE[ ]*\S*[ ]*\s*[ ]*GO").unwrap();
let string = "IF EXISTS(SELECT 1 FROM sysobjects o, sysusers u WHERE TYPE = 'P' and o.name = 'DI_GetFidelityRetirementEnterprise' and o.uid = u.uid and u.name = 'Escher')
DROP PROCEDURE [Escher].DI_GetFidelityRetirementEnterprise
GO";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}